Changes to Web browsers usable on Amilia

Posted on Nov 3, 2015 11:05:22 AM by Marianne David

Technology is evolving constantly... as are threats to the security and integrity of personal data entered on the Internet. In order to provide its users with a safe and secure environment they can trust and to ensure that we are doing everything in our power to protect your participants' confidential information, Amilia remains compliant with the PCI DSS standard, a strict set of rules created by the credit card industry which requires re-certification by a third-party every three months.

In order to retain our PCI DSS compliance certificate, starting on Thursday, October 29th, Amilia must block users attempting to connect with outdated web browsers. As of this Thursday, only the following browsers (or more recent versions) will be able to connect to Amilia: 

  • Internet Explorer 11

  • Chrome 22

  • Firefox 27

  • Safari 7

  • Opera 14

  • Android 4.4

  • Java 8

Older versions of these browsers have been deemed too vulnerable to hacking and malware, and they can no longer be authorized. Any service provider wishing to retain their PCI DSS certification and to continue processing credit cards and managing personal information must adhere to these rules. 

This unfortunately means that a small percentage of your clients may no longer be able to connect to Amilia and other service providers online. If a client is telling you they are having trouble registering, please ask them what browser they are using, then suggest the tips below, as needed.

 

SOME TIPS FOR YOUR USERS

  • Update your browser - it will keep you safer online.

  • Use a tablet or smartphone. The Amilia store can easily be accessed on mobile!

  • Windows XP users should be using Firefox

 

To assist your users and answer their questions, suggest this article that will help explain the situation.